WordPress 3.2.1: corretta incompatibilità JSON, nessun problema di sicurezza

WordPress 3.2 è stato scaricato oltre 1.000.000 di volte e, a distanza di una settimana, è stato rilasciato l’aggiornamento 3.2.1.

Questa versione si è resa necessaria per correggere un’incompatibilità con alcuni server legata a JSON. Tra le informazioni raccolte in rete, sembra che possa essere la causa del malfunzionamento di alcuni plugin che si connettono con Facebook utilizzando JSON.
[banner336]

Oltre a questo, sono state corrette alcune imperfezioni nel design del pannello di amministrazione e nel tema Twenty Eleven. Fortunatamente non sono stati segnalati problemi di sicurezza.

Questo aggiornamento sarà il primo a sfruttare la nuova procedura introdotta con WordPress 3.2, che prevede lo scaricamento e la sostituzione dei soli file modificati e non dell’interno applicativo. Il tutto, quindi, dovrebbe essere più veloce e più sicuro. In ogni caso è sempre meglio cautelarsi con un backup completo di file e database.

Per maggiori informazioni si può far riferimento ai ticket chiusi e al changelog.